Overview
6sense Connected Apps are no longer the recommended or supported method for integrating third‑party applications. To align with Salesforce security and platform standards, 6sense uses 6sense External Client App (ECA). This is the only supported method for connecting 6sense to Salesforce.
6sense ECA provide a more secure and future‑proof authentication model than legacy Connected Apps.
This approach offers:
Salesforce‑supported OAuth flows
Stronger security controls and token management
Improved lifecycle and app governance
Prerequisites
Before connecting or migrating, ensure the following:
You have Salesforce Admin access
You can install Salesforce packages for all users
Install 6sense External Client App
A Salesforce Admin must install the 6sense ECA package.
Installation links:
Production https://login.salesforce.com/packaging/installPackage.apexp?p0=04tOH0000003W1lYAE
Sandbox https://test.salesforce.com/packaging/installPackage.apexp?p0=04tOH0000003W1lYAE
Select Install for all users.
Acknowledge the checkbox.
Select Install.
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Verify installation
After installation:
Log in to your Salesforce org
Go to Setup.
Navigate to Apps → External Client Apps → External Client App Manager
Confirm that 6sense External Client App appears with:
Type: Packaged
Status: Installed
This confirms that the External Client App is installed successfully.

Configure External Client App policies
After installation, update the app policy settings.
In External Client App Manager, select 6sense External Client App.
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Go to Policies.
Select Edit.
In the App Policies section , select None in the Start Page drop-down.
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In the OAuth Policies section, configure the policies as shown below:
Setting | Required value |
|---|---|
Permitted users | All users can self‑authorize |
In the App Authorization section, select Expire refresh token if not used for specific time and configure the policies as shown below:
Setting
Required value
Refresh Token Validity Period
30
Refresh Token Validity Unit
Day(s)
IP Relaxation
Enforce IP restrictions
Session Timeout in Minutes
1 - 1440
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Save your changes.
Troubleshooting
*Error: App not installed
Error code: OAUTH_EC_APP_NOT_FOUND
Cause
The External Client App is not installed in Salesforce.
Resolution
Ask your Salesforce Admin to install the 6sense External Client App
Retry the login process
*Error: App disabled
Error code: OAUTH_FLOW_DISABLED
Cause
The External Client App or OAuth settings are disabled.
Resolution
Ask your Salesforce Admin to open External Client App Manager.
Select 6sense External Client App.
Ensure:
The app is Enabled
OAuth is enabled
Save the changes and retry login
The app name may not appear as Sixsense Staging Test.
FAQ
Does the single 6sense ECA support SFDC CRM, Pardot, and Salesforce Sales Engagement integrations?
Yes. The single 6sense ECA supports SFDC CRM, Pardot, and Salesforce Sales Engagement integrations.